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About MailMaven
MailMaven is a full-featured email app for Mac that includes sophisticated 
features for processing and organizing your mail similar to those in SmallCubed’s 
earlier plugin for Apple Mail, MailSuite.

Note: This documentation helps you get comfortable with MailMaven’s primary 
features, focusing on what tools, capabilities, and interface items exist and what 
they do. For a task-oriented (and far more detailed) look at MailMaven that 
explores even the more esoteric features, read Joe Kissell’s ebook Take Control 
of MailMaven.

The MailMaven Approach
Apart from the ordinary tasks of receiving and viewing email, MailMaven’s overall 
philosophy involves four elements, which we refer to using the acronym POMS: 
process, organize, monitor, send:

● Process: Do something—anything—with incoming messages, or even those 
that have been sitting on your Mac for a while. Processing messages (espe‐
cially automated processing) keeps inbox clutter under control with a minimum 
of effort and makes it easier for you to find things later. Examples of process‐
ing include applying rules to take various actions on messages as they come 
in (or on demand later), moving or copying messages using keyboard short‐
cuts, and filtering out spam. 

● Organize: MailMaven’s extensive tagging features enable you to apply 
metadata such as keywords, colors, projects, notes, importance, flags, review 
dates, and more to your messages. Then use that metadata later to zero in on 
exactly the messages you need in a flash.

● Monitor: Use smart mailboxes, conversations, and MailMaven’s detailed 
reviewing and tracking system to be sure nothing slips through the cracks. 
MailMaven can help you remember which messages are still awaiting replies, 

https://www.takecontrolbooks.com/mailmaven/?pt=MAVENDOCS
https://www.takecontrolbooks.com/mailmaven/?pt=MAVENDOCS
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which ones need additional attention from you in the future (even if they’re no 
longer in your inbox), and how a complicated, branching email thread fits 
together.

● Send: Send messages immediately, a fixed amount of time in the future, or on 
a specific schedule. And, using MailMaven’s templates, you can easily 
customize the look, feel, and contents of those messages.

Migrating from Apple Mail
When you opened MailMaven for the first time, you should have seen a window 
offering to take you through the steps of migrating your existing accounts 
(including both their settings and their message) from Mail. Assuming you 
stepped through that process, some or all of the data in Mail should now be in 
MailMaven. (If you didn’t import one or more accounts at the beginning, go to 
Settings > Accounts > Mail Accounts and click the Import  icon at the bottom of 
the account list to perform the migration now.)

Although importing your accounts, mailboxes, and messages from Mail gets you 
off to a great start, MailMaven makes no attempt to migrate other Mail settings 
(including things like signatures and rules), so you’ll have to recreate those things 
on your own.

As of version 1.0, there are several features found in Mail that MailMaven does 
not have. Here are a handful of these, just as examples:

● No support for POP accounts.

● A rule action can’t trigger an AppleScript.

● There’s nothing similar to MailDrop, which automatically uploads large attach‐
ments to the cloud and inserts a link instead.

● There are no VIP senders or muted conversations as such, though you can 
largely replicate their effects using tags and/or rules.
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If these or other “missing” features are important to you, take heart: Small‐
Cubed’s wish list for future versions is long, and over time, you’ll likely see most 
of the things you wish you had now. (You can see lists of known issues and 
feature requests on the SmallCubed website.) 

Tip: Joe Kissell’s ebook Take Control of MailMaven will contain considerably 
more information about migrating from Mail.

Those items aside, MailMaven doesn’t look just like Mail (on purpose!). Many 
elements have different names, locations, and icons. Some of the behaviors 
might initially seem unexpected, though keep in mind that you can customize 
hundreds of things about MailMaven (see The Settings Window and throughout 
this documentation). Our advice is that if something doesn’t seem quite the way 
you expect:

● First, try doing things the (default) MailMaven way. After a few hours or days, 
you might find that you get used to this approach, or even prefer it!

● If something is still bugging you, check through the settings (and this docu‐
mentation) to see whether there’s a way to adjust it. There probably is!

Migrating from MailSuite
What if you used SmallCubed’s MailSuite plugin in Mail, back when Apple still 
supported plugins? You may be in luck. Assuming you’re now using the same 
Mac that was running MailSuite—or that you migrated all your MailSuite settings 
from another Mac to this one, the majority of your settings should transfer over. 
(Not everything, sorry, due to changes in architecture.) And, if you set up a 
sync profile with MailSuite, you can sign in to the very same account in Mail-
Maven and all the tags you created with MailTags will transfer to the corre-
sponding messages.

https://mailmaven.app/support/known_issues.html
https://mailmaven.app/support/feature_requests.html
https://www.takecontrolbooks.com/mailmaven/?pt=MAVENDOCS
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The Main Window
MailMaven’s main window, the viewer window, is where you’ll spend most of your 
time. It’s where you see your mailboxes, messages, and other controls for 
managing your email.

Note: You can open more than one MailMaven viewer window, each with 
different view and sort settings. To open a new window, choose File > New 
Viewer.

The viewer window is divided into three main sections (the sidebar; the message 
list, which also has special controls for navigating conversations; and the 
message pane). See the following pages for details:

● Sidebar

● Message List

● Conversations

● Message Pane/Window

Tip: Even though, as everyone knows, purple is the greatest of all colors, if 
you’re not digging the shade of MailMaven’s windows and icons, you can change 
it: go to Settings > General > Application and choose a different hue from the 
Theme Color pop-up menu.

Sidebar
On the left side of the main MailMaven window is the Sidebar, which provides 
navigational tools. This is your starting point for finding your way around the 
mailboxes, tags, and other organizational features in MailMaven.
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Sidebar Categories
The Sidebar offers five different views that you can switch among by clicking the 
icons at the top. If you’re ever lost, try the Account Mailboxes  view, where 
you can find the Inbox and other mailboxes for each of your accounts.

Account Mailboxes
Click Account Mailboxes  to show the mailboxes for all your accounts. Each 
account has its own Inbox, along with other standard mailboxes such as Archive, 
Trash, Junk, Drafts, and Sent Messages and any user-created mailboxes. (To 
add or remove accounts, go to Settings > Accounts Settings.)

Besides account-specific mailboxes, the All Accounts portion of the sidebar dis‐
plays group Inboxes, Archives, Trash, Junk, Drafts, and Sent Mail for all your acc‐
ounts, so you can see these mailboxes for all your accounts together in one place.

You may also see a Maven Local entry in the Sidebar, which contains mailboxes 
stored only on your Mac and not in any online account.

Tip: You can rearrange the order of the accounts in the Sidebar (including All 
Accounts and Maven Local) by dragging the account icon up or down in the list.

To collapse or expand the mailboxes within any account or category, click the 
disclosure arrow (  or ) to its left.

Favorites
Click Favorites  to display all the items you’ve marked as favorites. If you have 
large numbers of mailboxes, tags, and other organizational elements, selecting 
your most commonly visited spots as favorites can help you navigate to them 
more quickly.

You can favorite any account, mailbox, smart mailbox, tag, tag category, or 
review mailbox in three ways:

● Control-click (or right-click) it and choose Add to Favorites.
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● Drag it to the Favorites  icon at the top of the Sidebar, then drag down to the 
specific spot where you want it to appear.

● Click the plus  icon at the bottom of the Favorites list and choose a prede‐
fined Favorite Group from the pop-up menu.

Mailboxes you’ve marked as favorites display a small star  icon in their original 
location.

In addition to the Favorite Groups shown when you click the plus  icon, such 
as Smart Mailboxes and Recent Mailboxes, you can create your own Favorite 
Groups to further organize your Favorites. To create a custom Favorite Group, 
click the plus  icon and choose Add Favorite Group. Type a name for the 
group, optionally select a color, and if you to see all the messages in that group 
when you select it, also check “Display messages of member mailboxes.” Click 
OK. You can then drag any existing Favorites into that group.

To edit any Favorite or Favorite Group, either select it and click the Edit  icon 
at the bottom, Control-click (or right-click) it and choose Edit Favorite, or (in the 
case of custom Favorite Groups) double-click it . You can then change the name, 
color, and message display as shown above.
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Tip: You can use the Export  and Import  icons at the bottom of the sidebar 
to export or import your Favorites settings (as a backup, or to transfer to 
another Mac).

Smart Mailboxes
Click Smart Mailboxes  to display a list of smart mailboxes you’ve created. A 
smart mailbox is essentially a saved search; every time you select it, it shows an 
up-to-date list of messages matching the criteria you set.

To create a smart mailbox, do either of the following:

● Choose Mailbox > New Smart Mailbox.

● Click the plus  icon at the bottom of the Smart Mailboxes list.

● Select an existing smart mailbox and click the Duplicate  icon to copy it as a 
starting point for a new one.

In the popover that appears, specify the condition(s) that must be met for a 
message to be included in the list. The interface and conditions are almost 
identical to those for rules (refer to Rules), except that there are no actions 
associated with smart mailboxes; the implicit action is to display a list of matching 
messages.

You can edit a smart mailbox later by double-clicking it.
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Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your smart mailbox settings (as a backup, or to transfer to 
another Mac).

Tag Mailboxes
Click Tags  to display tag mailboxes—that is, mailboxes for your user-defined 
keywords and projects, plus Importance and Flags. To learn about how to add 
these tags to your messages, see the following topics:

● Tagging Messages (for general information on tagging)

● Tag Types (to learn about the numerous types of tags)

● Adding Tags (for tagging outgoing messages manually)

● Applying Tags with Rules (for tagging messages automatically)

Review Mailboxes
Click Review Mailboxes  to display special mailboxes with messages that may 
require your review—for example, because you set a review date that’s today, 
tomorrow, or in the past; you’re expecting a reply; or the message arrived 
recently and is still unread. For ways to apply these tags, see Adding Tags, 
Setting Delivery Options, and Tag Settings.

The available review mailboxes are as follows:

● Unread: The unread messages from all mailboxes

● Review: Messages tagged for review in some way:

▶ Review Today: Messages with a review date of today

▶ Review Tomorrow: Messages with a review date of tomorrow

▶ Past Due: Messages whose review date is in the past

▶ Upcoming: By default, messages whose review date is two or three days in 
the future



14

▶ Future: By default, messages whose review date is three or more days in 
the future

Note: You can change the definition of Upcoming and Future in Settings > Tag > 
Review.

▶ Expecting Reply: Messages—usually sent messages—to which you’ve 
applied the Pending Keyword (“Pending” by default); see Review Tab

▶ Tag Conflicts: Messages for which there are two or more sets of tags that 
don’t match, often as a result of changing tags on a message on two 
different Macs, one of which is offline at the time

● Recent: Messages received in one of the following time frames:

▶ Today

▶ Yesterday

▶ This Week

▶ Last Week

▶ This Month

Note: You can’t add your own custom review mailboxes.

Message List
To the right of the sidebar in the main MailMaven window is the message list, 
which is just that: a list of messages in whichever account, mailbox, or other 
category is currently selected in the sidebar. Click a message to display its 
contents and interact with it; for more detail about the message contents, see 
Message Pane/Window.

MailMaven provides extensive control over what shows up in the message list 
and how it appears.



15

View Options
The message list can appear as a vertical column (Snippets, the default) or a 
horizontal pane (Table). Switch to table view by choosing View > Show Message 
List as Table; switch to snippet view by choosing View > Show Message List as 
Snippets.
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In snippet view, you can adjust how many lines of the message body appear 
under the title, from 0–4 lines, in Settings > View > Appearance > Viewer Layout 
by choosing the desired length from the Snippet Length pop-up menu.

Note: Wondering why some of your messages have a blue background? They’re 
part of a conversation; see Highlighting Conversations for details.

You can also choose which tags to display in the message list (in snippet view 
only) by using commands on the View menu, such as Show Keywords, Show 
Review Date, and Show Importance.

Unread/Total Icons
At the very top of the window above the message list you’ll see one or two 
numbers . The rightmost number indicates the total number of messages in 
the selected mailbox. The number of unread messages, if any, is shown to the 
left of that with a blue dot in the corner. (If you see only one number, that’s the 
total number of messages.)
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Click the unread count to filter the list to show only unread messages; click the 
total number to reset the list to include all messages.

Sort/Group Controls
The message list can sort messages by any of 
numerous criteria, such as Date Received (the 
default) or Date Sent, Sender, Size, and the pres‐
ence of attachments. To change the sort criterion, 
choose the one you want from the left-hand pop-up 
menu above the message list. To change the sort 
direction, choose Ascending or Descending from 
that pop-up menu; the arrow (  or ) shows the 
current direction.

Besides sorting your messages, you can also group 
them under headings indicating their relative status. 
For example, grouping messages by Date Received 
may have labels for “Received Today,” “Received 
This Week,” and Received current month,” while 
grouping by attachments might have headings like 
“7 Attachments,” “1 Attachment,” and “No Attach‐
ments.”

To switch from regular sorting to sorting with grouping, choose Group Messages 
from the pop-up menu. All the menu commands then change from “Sort by” to 
“Group by.”

Filter Controls
An optional filter temporarily reduces the number of messages shown in the list 
according to criteria you specify—for example, only unread messages or those 
for which you were a Cc recipient.
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To filter the current message list, choose the criterion you 
want, such as Unread or Tagged, from the pop-up menu 
next to the Filter  icon at the top of the message list.

If you choose Phrase, a Filter field appears, along with a 
pop-up menu next to the Filter  icon. Initially, that pop-
up menu is set to Phrase, meaning you can type a word 
or phrase into the Filter field and MailMaven filters the 
currently shown message list to include only messages 
with that text in the message (including the headers and 
body).

Note, however, that the criteria on that menu are 
additive: you can filter by both a phrase and unread status, for example; to turn 
off any criterion, choose it from that pop-up message again.

To turn off filtering, choose All Messages from the pop-up menu.

Note: Clicking the Filter  icon itself toggles filtering by phrase.

Conversations
In MailMaven, a conversation is any set of two or more connected messages. 
The simplest conversation is a single message and its reply—for example, a 
message you sent and a reply to that message, or a message your received and 
your own reply. However, conversations can also be complex threads involving 
many participants over a long period of time, such as when you send a group 
email and various group members reply to you and to each other in extended 
exchanges. Forwarded messages are also parts of conversations.

MailMaven offers several tools to help you find your way through even the most 
complex conversations.
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Grouping Messages by Conversation
Regardless of the message list’s current sort or grouping order (see Sort/Group 
Controls), you may want all the messages from the current mailbox that are part 
of the same conversation to appear together, making it easier to follow the 
conversation. To group messages for the current mailbox by conversation, 
choose View > Group Messages by Conversation. (If you do not have messages 
grouped by conversation but you do have conversations highlighted as described 
just ahead, selecting any message also highlights the other messages from that 
conversation in the current mailbox.)

When messages are grouped by conversation, you’re in snippet view, and 
messages must are sorted by Date Received or Date Sent, a conversation  
icon appears on the right side of the group; the number in the circle indicates 
how many messages from the conversation are in the currently selected mailbox. 
A plus (+) icon in the upper-right corner of the conversation icon indicates that 
there are more messages from the conversation in other mailboxes.

To expand or collapse a single conversation in the message list, regardless of 
whether you’re in snippet view or table view, press the right arrow ▶︎ or left arrow 
◀︎, respectively. In snippet view only, you can also click the conversation  icon 
to toggle the display of additional messages from the conversation in the current 
mailbox.

Tip: To expand or collapse all conversations from the current mailbox at once, 
choose View > Expand All Conversations or View > Collapse All Conversations.

Highlighting Conversations
By default, MailMaven’s message list displays a blue background for every 
message that’s part of a conversation, even if the other message(s) aren’t in the 
same mailbox (see Conversations). If you prefer not to see that highlighting, you 
can turn it off by choosing View > Highlight Conversations.
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Using the Conversation Map
MailMaven’s conversation map is a list of all the messages in a conversation, 
with connecting lines showing which messages were replied to and by whom. 
Because conversations (especially those involving several people) can branch 
out in nonlinear ways, a conversation map helps you keep track of the flow of 
information among parties. You can display the conversation map either in a 
popover or in a separate floating panel, as you prefer.

To display the conversation popover momentarily (just to glance at the conversa‐
tion), click and hold the conversation  icon or the Conversation Map  icon 
at the top of the message preview. The popover appears only as long as you 
hold down the mouse button.
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To make the popover stay open, in‐
stead right-click (or Control-click) the 
conversation  icon or click the 
Conversation Map  icon at the 
top of the message preview.

Note: The popover is available only 
when the conversation  icon ap-
pears, which is to say, only when 
the currently selected mailbox con-
tains more than one message from 
the conversation.

To display the floating conversation 
panel, select a message from the 
conversation and choose View > 
Show Conversation Panel (⌘-') or 
right-click/Control-click the conversa‐
tion  icon.

When the conversation map is visi‐
ble, click any message in it to jump 
to that message; double-click it to open it in a new window. Unread and total 
message counts appear at the top of the conversation map, just as in the main 
message list.
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Message Pane/Window
The message pane occupies the largest portion of the main MailMaven window, 
displaying the contents of the message along with its headers, any attachments, 
and various controls for working with the message. If you prefer to open a 
message in a separate window, you can double-click it in the message list or 
choose Message > View in New Window (⌘O). The appearance and controls 
are the same in both cases.

Subject
The message subject appears at the 
very top of the window. If the mes‐
sage is part of a conversation, de‐
tails about the conversation appear below the subject (such as “5 Messages in 
Conversation, 0 Unread”).

Message Header
The message header area is a gray box below the subject that shows:

● The sender’s name and address

● The date and time the message was received

● The name(s) and address(es) of the recipient(s), including any Cc recipients

● The sender’s original subject, if you’ve changed it using Alternate Subject

● The mailbox the message is in, along with an icon representing its account

● For messages that have been encrypted and/or digitally signed, a Security line 
with additional information (see Encrypting and Digitally Signing Messages)

● A list of attachments, if any, along with their total size; see Attachments, 
ahead

● Tags you’ve added such as Keywords, Notes, and Project.
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Remote Content Control
If the message contains images or other media that must be downloaded to be 
displayed, a banner appears below the message header saying “This message 
contains remote content.” By default, MailMaven does not display this material 
because downloading media can signal to the sender not only that you’ve read 
the message but also when you did so and where you’re located. However, if you 
want to load the media, click the Load Remote Content button, which loads the 
material just once.

You can also click the arrow on the right side of the control and choose Load 
Once (for the same effect), Always Load For This Message (which remembers 
the setting for this particular message), or 
Always Load For This Sender (which loads 
the remote content for all messages from 
the same address).

Note that MailMaven does load remote content from people in your Contacts, but 
you can disable this (or extend it to everyone) by going to Settings > View > 
Message Display > Images and either deselecting Load Remote Media or 
choosing Everyone from the From pop-up menu, respectively.
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Attachments
Message attachments appear next to the attachment  icon in the message 
header. If a message has more attachments than can fit in a single row, click the 
ellipsis  icon to display the rest below.

You can select an attachment icon and press the Space bar to preview it with 
Quick Look, double-click it to open it in its default app (such as Preview), or drag 
it to your desktop or another window to save it outside MailMaven.

Most attachments also appear in the body of the message, though whether this 
happens depends on the 
sender’s email app and how the 
message was formatted. Click‐
ing or double-clicking an attach‐
ment in the body of the message works as in the message header, and drag-
and-drop usually works.

Non-graphical attachments, including PDFs, generally appear at the bottom of 
the message in a gray box. You can either drag the icon in this box or click the 
Save  icon to choose a destination on your Mac to save the file.

Basic Message Controls
MailMaven offers the usual array of controls for working with messages, such as 
replying, forwarding, and deleting, plus a wide range of tagging features. In most 
cases, you can accomplish any of these tasks by using icons, menu commands, 
or keyboard shortcuts.

By default, a group of icons called the Message Action Bar appears to the right of 
the message content; these controls act only on that particular message. If you 
prefer, you can move this to the left or top by going to Settings > View > Mes‐
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sage Display > Message Action Bar and choosing Left or Top from the Location 
pop-up menu; you can also use the Visibility pop-up menu to control whether the 
bar is always visible or if it appears only when your mouse pointer is inside the 
message.

The controls on the Message Action Bar and their corresponding menu com‐
mands and keyboard shortcuts are:

● Reply : Message > Reply (⌘R)
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● Reply All : Message > Reply All 

● Forward : Message > Forward (⌥⌘F)

● Tag Message : For individual messages, this icon is equivalent to Mes‐
sage > Set Tags (⌃⌘T). However, note that if the message is part of a 
conversation, Message > Set Tags (⌃⌘T) applies to the entire conversation 
(see Conversation Controls, below).

● Mark as Junk : Message > Mark as Junk (⌘J)

● Archive Message : Message > Archive (⌃⌘A)

● Print Message : File > Print (⌘P)

● Action : By default, this icon applies keystroke rules (Message > Apply 
Keystroke Rules, F2). However, you can configure it to show the Action Panel 
(F1) or the Move to Mailbox panel (Message > Move to Mailbox, F3) by going 
to Settings > View > Message Display > Message Action Bar and choosing a 
command from the Action pop-up menu.

● Delete Message : Message > Delete (Delete). This command moves the 
selected message(s) to the Trash mailbox.

Tip: For more message-related controls, see the Message menu.

Conversation Controls
If a message is part of a conversation (see Conversations), an additional block of 
conversation controls called the Conversation Action Bar appears to the right of 
the subject. These icons apply to every message in the conversation.

The controls on the Conversation Action Bar and their corresponding menu 
commands and keyboard shortcuts are:
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● Conversation Map : View > Show Conversation Panel (⌘-'), except that 
this icon displays the conversation map in a popover, whereas the menu 
command and keyboard shortcut display it in a floating panel

● Tag All Messages : Message > Set Tags (⌃⌘T)

● Archive Conversation : Message > Archive (⌃⌘A)

● Print Conversation : File > Print (⌘P)

● Action : By default, this icon applies keystroke rules (Message > Apply 
Keystroke Rules, F2). However, you can configure it to show the Action Panel 
(F1) or the Move to Mailbox panel (Message > Move to Mailbox, F3) by going 
to Settings > View > Message Display > Message Action Bar and choosing a 
command from the Action pop-up menu.

● Delete Conversation : Message > Delete (Delete). This command moves 
all the messages in the conversation to the Trash mailbox.
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The Compose Window
When you create a new message (File > New Message, ⌘N), reply to a mes‐
sage, or forward a message, the window in which you write or edit the outgoing 
message is the compose window. Because it’s designed to create and not 
merely display messages, it has quite a few features not found in the viewer 
window.

Window Controls
This image shows the main controls in the compose window.
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At the top is the subject (“New Message” is replaced with whatever you type in 
the Subject field). To the right of that is the toolbar, with the following controls:

● Search in Message : To search within the contents of the message you’re 
composing, click this icon or press ⌘F.

● Attachments : Click this icon, which appears both at the top and the 
bottom of the compose window, and navigate to a file to attach it to the 
message. You can also drag in a file from the Finder.

● Toggle Delivery Options : Click this to display the Delivery Options Bar in 
your message (see Setting Delivery Options, below).

● Toggle Tags : Click this to display the Tag Bar in your message; the Tag 
window also appears automatically. See Adding Tags, below, for an overview 
or see Tagging Messages for complete details.

● Toggle Formatting Bar : Click this to display the Formatting Bar in your 
message (see Formatting Messages, below).

● Optional Fields : Click this icon to display a pop-up menu that lets you 
toggle the display of the Cc, Bcc, and Reply-To fields. Note that MailMaven 
remembers your choice here and displays the same fields in future messages.

In the header portion of the message are these controls:

● Address and Subject Fields: The To (and optionally Cc, Bcc, and Reply-To) 
fields and the Subject field, which can’t be blank. See Addressing Messages.

● From pop-up menu: Choose the account and email address from which you 
want to send the message from this pop-up menu. Addresses marked with a 
lock  icon are those for which you can encrypt or digitally sign messages 
(see Encrypting and Digitally Signing Messages).

● Encryption and Digital Signature icons  : If your From address is 
configured to support encryption and digital signatures (again, see Encrypting 
and Digitally Signing Messages), these icons become visible.
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Below that, you may see one or more additional bars (see Adding Tags and 
Setting Delivery Options), followed by:

● Composer: The main, blank portion of the compose window is the composer, 
where you type and format your messages.

● Signatures pop-up menu : Use this menu to choose a signature you’ve 
previously created and associated with this account. See Create Signatures 
for details.

● Send button: Click this (or press ⇧⌘D) to send the message.

Formatting Messages
You can apply the usual range of formatting (font, size, color, style, alignment, 
lists, indentation, block quoting, links, and inline attachments) to any message 
using controls on the Formatting Bar or the Compose menu. If you don’t see the 
Formatting Bar, click the Toggle Formatting Bar  icon at the top of the 
window.

If you prefer to send a message in plain text, choose Compose > Plain Text. 
Note, however, that even when you switch to Plain Text, formatting remains 
visible in the composer.

Addressing Messages
As you begin typing a name or email address in any of the address fields (To, 
Cc, or Bcc), MailMaven displays matching results from Contacts as well as 
people you’ve previously emailed. Click the one you want (or use the arrow keys 
to select it and press Return). You can also, of course, simply type or paste a 
complete address.
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Note: A silhouette  icon next to an address means it’s found in Contacts; a 
lock  icon means MailMaven has a copy of that person’s public key, so you can 
send them encrypted messages.

Adding Attachments
To attach a file without displaying it in the body of the message (even if it’s a 
graphic), click the paperclip  icon, which appears both at the top and the 
bottom of the compose window, and navigate to a file to attach it to the message. 
You can also drag a file from the Finder to the Attachment area at the bottom of 
the window.

To place an attachment at a specific point in your message, position the insertion 
point where you want it to go, click the paperclip  icon on the Formatting Bar, 
and navigate to the file. Or, you can drag a file from the Finder into the body of 
the message.

Adding Tags
Tags (such as keywords, colors, projects, and review dates) help you monitor 
and locate messages. Just as you can tag incoming messages, you can also tag 
messages you’re composing. When you apply tags to outgoing messages, those 
tags are associated with the copy of the message in your Sent Mail mailbox.

To add a tag, click the Tag Bar if it’s visible (if it’s not visible, click the Toggle 
Tags  icon). In the popover that appears, enter whichever tags you like. (You 
can also tag outgoing messages using the commands on the Message menu.)

For complete details, see Tagging Messages.
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Setting Delivery Options
Ordinarily, when you click Send, MailMaven sends the message immediately. 
However, you have complete control over when the message is sent and what 
happens to your copy of the sent message afterward. To adjust delivery settings, 
make sure the Delivery Options Bar is visible; if not, click the Toggle Delivery 
Options  icon.

The bar has three pop-up menus:

● Schedule: This pop-up menu can have any of four settings:

▶ Using Rules: The default setting, this processes the message through any 
outgoing rules you’ve set up (for details, see Outbox Rules). If you have no 
outbox rules, or if this message doesn’t meet the criteria for any, the 
message is sent immediately. The Apply Rules bullet, just ahead, provides 
further options.

▶ Immediately: Send the message right away, skipping any outbox rules.

▶ After Delay: Send the message after a fixed number of seconds, minutes, 
or hours. When you choose After Delay, additional controls appear, allow‐
ing you to set the delay period.

▶ At Time: Send the message at a particular date and time in the future. 
When you choose At Time, a popover appears with a calendar and time 
selector.

Note: In order for After Delay and At Time to work, your Mac must be turned on 
and awake, and MailMaven must be open, when the message is scheduled to be 
sent. If it’s not, MailMaven will send the message the next time it’s online.

● Apply Rules: By default, when the Schedule is set to Using Rules, MailMaven 
applies all applicable outbox rules, but if you want to apply only specific 
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outbox rules to this outgoing message (or none at all), use the Apply Rules 
pop-up menu to make your selections.

● Archive To: Normally, your copy of each sent message is stored in the Sent 
Messages mailbox, a logical place for it. If you want this one to go somewhere 
else, choose Other from the Archive To pop-up menu and select a mailbox.

Adding a Signature
A signature, which typically appears at the bottom of a message you compose, 
lets you add information about yourself or your organization without having to 
retype it manually each time. A simple signature might include elements like your 
name, title, email address, or phone number.

But MailMaven enables you to create any number of custom signatures that 
include various types of static and dynamic text and images, extensive format‐
ting, and other features. You can then apply these signatures automatically or 
manually to outgoing messages.

If you’ve already set up at least one signature and assigned it to the account from 
which you’re sending a message, you can choose it from the pop-up menu in the 
lower-left corner of the compose window. (If you’ve set a default signature for this 
account, it appears automatically.) You can also choose None from that menu to 
remove the signature, or Edit Signatures to jump directly to Settings > Compose > 
Signatures, where you can create new signatures. (In that case, you might want 
to skip ahead to Encrypting and Digitally Signing Messages.)



34

If not, read on for details about creating signatures.

Note: Although you can get extremely fancy with MailMaven signatures, keep in 
mind that many recipients ignore signatures, and that the longer and more 
complex a signature is, the less likely it is that someone will read the whole 
thing.

Using signatures involves two broad elements:

● Creating one or more signatures and associating them with accounts (see 
Create Signatures, next)

● Setting a default signature for an account or overriding the default choice (see 
Setting Default Signatures and Choosing a Signature Manually, ahead)

Create Signatures
To create or edit signatures, go to Settings > Compose > Signatures.

Here, the overall process is:
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● Create one or more signatures, which appear in the All Signatures list ➊. The 
pane at the bottom ➋ shows the structure of the signature or, if Preview 
Signature ➌ is selected, what the signature will look like in your messages.

● Drag the signatures to the account(s) where you want them to be available ➍.

● For each account, use the Account Settings popover (not shown here) to 
specify default signatures, if any.

● If you want a signature to include information from the Music app or random 
quotations, set those up in the categories on the left side ➎.

To create a signature, follow these steps:

1. Click the plus  icon at the bottom of the signature list. An editing window 
appears.

2. In the top portion of this window, you can type any static text that you want to 
include in the signature (such as your title or address). Optionally use the 
formatting controls to add styling, links, and attachments. Formatting also 
applies to tokens (see About Tokens, next).
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3. Signatures can also include numerous dynamic elements—such as the email 
address or user name for the current account, a random quote, or the latest 
entry from your blog—indicated by blue tokens at the bottom (described next). 
Drag these tokens where you want the corresponding text or image to appear 
in your signature; when you compose a message, the tokens are replaced 
with the corresponding content.

4. When you’re finished designing a signature, click Save.

Note: To edit an existing signature later, either double-click it or select it and 
click the Edit  icon.

5. In order to use your signatures, you must associate them with one or more 
accounts. To do so, drag a signature from the All Signatures list to an account; 
repeat for every signature you want to use with every account.

Important: When sending email from any account, the only signatures you can 
use are ones you’ve added to that account per step 5.

Tip: You can specify where the signature should go in replies and forwards by 
setting the Signature Location token in those templates; see Create or Edit 
Templates.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your signatures (as a backup, or to transfer to another Mac).

About Tokens
The available tokens are grouped into four categories.

Account Tokens use information from whichever email account you’re using the 
signature with:

● Email: Your email address

● User Name: Your user name (or display name) 
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● Account Description: The title or name of the account, as shown in the 
mailbox list

● Obscured Email: A version of your email address with “dot” and “at” spelled 
out (as in “support at smallcubed dot com”, to reduce the likelihood of the 
address being used to create spam lists

An example signature using account tokens, and how it appears in your 
message:

Quotes Tokens are used with lists of Quotes (described ahead):
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● Quotation: Any quotation of interest to you

● Quote Author: Who originated the quote

● Quote Citation: The work from which the quote was taken

● Quote Category: The type of quote, such as Humor or Work

Content Tokens add more complex material to quotes:

● Image: Insert an image found on a web server. When you drag this token into 
the signature, a dialog prompts you for the image’s URL, alt text, and optional 
width and height.

● URL w/Image: Insert an image found on a web server, and make the image a 
clickable link. When you drag this token into the signature, a dialog prompts 
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you for the link’s URL, the image’s URL, alt text, and optional width and 
height.

● Script: The output of a script you provide (see Scripts, ahead).

● Blog Entry: A snippet of, and link to, the most recent entry in any RSS feed. 
When you drag this token into the signature, a dialog prompts you for the 
blog’s URL (which can usually be the homepage, not necessarily the URL for 
the RSS feed itself), an optional template specifying the layout of the snippet, 
text to put before the snippet (by default, “The latest word from ‘#feedTitle#’, 
where #feedTitle# is replaced with the blog’s name, and styling options for the 
text and border.
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Music Tokens add information about what’s happening in the Music app:

● Music Song: The name of the track currently playing in Music.

● Music Album: The name of the album from which the currently playing track is 
taken.

● Music Artist: The artist performing the current Music track.

● Music Composer: The composer of the current Music track.

● Music Status: The current status of the Music app (“playing,” “paused,” or 
“stopped”). “Stopped” also appears if Music is not open.

● Music Summary: The summary as set in the Music view (see Music Sum‐
maries, next).

The first four of these tokens display text in the signature only if Music is playing 
something.

Music Summaries
Another way to represent the current status in Music is to use a music summary, 
which appears wherever you place the Music Summary token. The music 
summary is one of four customized blocks—one each for when Music is playing, 
paused, stopped, and not running. Each block, can in turn, use any or all of the 
other Music tokens.

To create music summaries, select Music on the left side of the Signatures page. 
Then click in one of the four fields (Playing , Paused , Stopped , and Not 
Running ). In the dialog that appears, type any desired text and use the tokens 
to represent what you want your signature to say when Music is in that state.
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Quotes
Select Quotes on the left to configure quotations to be used when a signature 
contains Quotation, Quote Author, Quote Citation, or Quote Category tokens. 
Maven chooses a random quotation from the selected categories each time you 
compose a message using that signature.

You can select any or all of SmallCubed’s prewritten quotes (in categories such 
as Humor, Philosophy, and Work), or create and import a file with quotations of 
your choice.

To use your own selection of quotes, first create a text file in the following JSON 
format and store that file somewhere on your Mac or at a publicly reachable web 
address:
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{

    "name": "Category Name",

    "description": "Category Description",

    "quotes": [

      {

        "q": "The Quotation",

        "a": "The Author",

        "c": "A Citation"

      }

    ]

}

Example JSON file (for example, quotes.json):

{

    "name": "H2G2",

    "description": "Quotes from the Hitchhiker’s Guide to the Galaxy",

    "quotes": [

      {

        "q": "Time is an illusion. Lunchtime doubly so.",

        "a": "Douglas Adams",

        "c": "The Hitchhiker’s Guide to the Galaxy"

      },

      {

        "q": "He felt that his whole life was some kind of dream and he 

sometimes wondered whose it was and whether they were enjoying it.",

        "a": "Douglas Adams",

        "c": "The Hitchhiker’s Guide to the Galaxy"

      }

    ]

}
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Within the quotations (“q”) sections, you can use common HTML tags such as 
<strong></strong>, <em></em>, <u></u>, and <br/>, as well as styling such as <span 
style='color:blue'></>span>.

Note: Be sure to use only single quotation marks in <span> tags.

Once your file is ready, import it into MailMaven by clicking the plus  icon at 
the bottom of the Random Quotation Categories list and either navigating to the 
local file or entering the URL for the file if it’s online.

Tip: Be sure to select your imported file in the Random Quotation Categories list 
and confirm that the quotations you put in it appear correctly at the bottom. If 
not, that means there was an error in the JSON file.

With your quotation categories selected, create a signature that uses any or all of 
the items in the Quotes category.
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Scripts
Signatures can include the output of scripts, such as shell scripts and Apple‐
Scripts.

Note: This is an advanced feature and requires considerable scripting experi-
ence. SmallCubed can’t offer support with script writing.

To add a script, drag the Script token into your signature. MailMaven prompts 
you to select a file containing the script; note that this can be anywhere on your 
disk. Then a dialog appears in which you can optionally provide arguments to the 
script, set a timeout, embed the output as HTML, or surround the output in 
<pre></pre> tags, which also eliminate any line breaks within the script output.

Here are two very simple examples.

To show the local weather, save the following shell script as weather.sh, and add 
that Script to your signature. If you fill in a place name as the argument, the script 
returns the weather for that location; otherwise, it tries to guess your current 
location.

#!/bin/bash

if [ -z "$1" ]; then                                                                                                                                             

    curl "wttr.in?0T" 2>&1 | sed '1,3d' | sed -E 's/^ .{13}//' | sed -E 's/

^( |―) +//'

else

    curl "wttr.in/$1?0T" 2>&1 | sed '1,3d' | sed -E 's/^ .{15}//'

fi

The output might look something like this:
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Here’s a simple AppleScript that use the current day of the week:

set theday to weekday of (current date) as string

return "Today is " & theday & " and you know how I feel about " & they & 

"s."

And here’s what it might look like in a signature:

Setting Default Signatures
Each email account can have a default signature, and if more than one email 
address (or alias) is associated with an account, each one of them can have its 
own default signature.

To set up default signatures:

1. Click the Edit Account Settings  icon next to an account in Settings > 
Compose > Signatures.
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2. To use the same signatures for all the addresses in the account, leave “Use 
same settings for all addresses/aliases” checked. To use different settings for 
each address, uncheck that and select an address.

3. From the pop-up menus under Default Signatures, choose which signature 
you’d like to use for new messages, replies, and forwarded messages. If you 
selected just a single address in step 3, repeat this process for each address.

Note: The only addresses that appear in these pop-up menus are those you’ve 
previously added to this particular account; see step 5 under Create Signatures.

Choosing a Signature Manually
When composing a message, you can override the default signature by clicking 
the pop-up menu in the lower-left corner of the compose window and choosing a 
different signature from the list. Remember, this list shows only those signatures 
you’ve previously added to this account.

Encrypting and Digitally Signing Messages
MailMaven can encrypt and/or digitally sign messages using PGP (or its open-
source counterpart, GPG/GnuPG).

A digital signature (unlike a conventional, visible signature) is extra, hidden code 
added to your message that the recipient’s email app can use to verify that you 
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(the person whose address is on the message) were really the one who sent it, 
and that it wasn’t changed or tampered with in transit. You can sign a message 
without encrypting it, but if you encrypt a message, it’s also signed.

Before you can sign or encrypt an outgoing message (or decrypt a message sent 
to you), you must have a PGP public/secret key pair. Various software tools, 
including the free version of GPG Suite from GPGTools, can create these keys. If 
you have a key pair already you can import it by going to Settings > Secure and 
using the Import  icon at the bottom of the pane.

Alternatively, you can create the keys right in MailMaven: click the plus  icon at 
the bottom of the Settings > Secure pane and choose Generate New Key from 
the pop-up menu. Select the email address to be associated with the key, enter 
and confirm a passphrase (be sure to make a note of this in your password 
manager!), and click OK.

Having done that setup, if you’re composing a message with a From address for 
which you have a secret key, you can sign it by selecting the seal  icon to the 
right of the From address; the icon then turns green . Click Sign and Send to 
send the message.

Before you can encrypt an outgoing message, however, an additional step is 
required: you must add their PGP public key to MailMaven. To do so, go to 
Settings > Secure, click the plus  icon at the bottom of the pane, and choose 
Look Up Key from the pop-up menu. Type in the person’s email address and 
click Search. Then select the matching key and click Import.

When addressing an outgoing message, recipients for whom you have public 
keys display a lock  icon. Once the address is filled in, you can click the open 
lock  icon to the right of the From address, which then turns into a closed, 
green lock  icon. Click Encrypt and Send to send the message.

https://gpgtools.org/
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Using Templates
When you create a new message, reply to a message, or forward a message, 
MailMaven uses built-in templates to specify not only fonts and formatting but 
also the presence and placement of various elements (such as the signature, the 
attribution line (e.g., “On Monday, June 9, 2025, John Smith wrote:”), the way 
quoted text appears, and so on.

Not only can you customize every aspect of these default templates, you can 
also create as many custom templates as you like, each containing different 
elements along with boilerplate text and graphics. You can then specify which 
template to use when composing or replying to a message. (Currently, Forward 
templates can be used only in rules.)

Create or Edit Templates
To create or edit templates, go to Settings > Compose > Templates. The Default 
Templates section at the top lists the templates used automatically when you 
reply, create a new message, or forward a message. You can edit these to your 
liking by double-clicking them and making changes in the window that opens.
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In the main field, you can type and apply formatting using the controls at the top 
of the field, just as when you Create Signatures. You can also drag tokens from 
the bottom of the window to various spots in the field; these are replaced with the 
current value of that item when you use the template. To see what your finished 
template would look like, check the Preview Template with “Jane Doe 
<jane@smallcubed.com>” box. When you’re finished with your changes, click 
Save.

If you ever need to revert to one of the default templates as it originally appeared, 
right-click (or Control-click) it and choose Reset Template.

Creating your own template is nearly the same. Click the plus  icon at the 
bottom of the template list and fill in the window as above. Note that you must 
specify the template type (Reply or New) using the pop-up menu in the upper-
right corner. (To create a new Forward template, right-click or Control-click the 
default Template for Forward, and choose Duplicate.)
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Optionally, you can enter a single character in the Key field at the top, which is 
then used when you open the Compose with Template, Reply with Template, or 
QuickReply with Template panel.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your templates (as a backup, or to transfer to another Mac).

Use Custom Templates
Once you’ve created one or more custom templates, you can use them when 
composing messages in any of several ways:

● Choose File > New Message with Template (F6), also available from the 
Action Panel as Compose with Template.

● Choose Message > Reply with Template (F7) or Reply All with Template 
(Shift-F7), or hold down Option and choose Message > QuickReply with 
Template (Option-F7) or QuickReply All with Template (Option-Shift-F7).

● Right-click (or Control-click) a message and choose Reply with Template or 
Reply All with Template from the pop-up menu, or hold down Option and 
choose QuickReply with Template or QuickReply All with Template.

In any of these locations, select the template you want to use in the panel that 
appear and press Return.

Note: As a reminder, you can use Forward templates only in rules at present.
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Message Processing
When messages arrive in your inbox, you’ll (usually) want to read them (and 
sometimes reply to or forward them), but then what? Whether you then delete the 
messages, file them into a mailbox, or perform some other activities with them, 
the next step is to process them in some way. If you’re an Inbox Zero person, 
your goal may simply be to get the message out of your inbox, but whatever your 
approach to managing email, it’s important to be able to distinguish messages 
you still have to deal with in some way with those you don’t. MailMaven’s 
numerous processing tools can turn an otherwise tedious step into a breeze.

Of course, you can drag a message manually to another mailbox, or press the 
Delete key to remove it. But MailMaven lets you perform most processing actions 
from the keyboard if you prefer, and can automate many of them.

The three main tools available for message processing are:

● Mail Actions, which give you streamlined ways to move, copy, and tag mes‐
sages

● Rules, which apply automatically to incoming and/or outgoing messages, and 
can also apply on demand via a keystroke

● Junk Mail filtering, using either spam headers set by your email server or 
external processing with SpamSieve

Mail Actions
Mail Actions enable you to process messages in various ways using a pop-up 
window that can be controlled entirely from the keyboard if you like. This window 
takes any of several different forms, depending on how you invoke it.
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Action Panel
The Action panel is a list of all the other Mail Action panels you can use. If you 
don’t want to memorize a long list of keyboard shortcuts, you can start with just 
one, F1, which gives you a launching point for all the other actions. (Of course, if 
you do memorize the other keyboard shortcuts, you may never use the Action 
panel at all.)

Tip: All the keyboard shortcuts shown here can be customized to your liking; go 
to Settings > General > Keystrokes (see Keystrokes Tab for details).
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The Action panel provides shortcuts to the following:

● Apply Keystroke Rules (F2)

● Move to Mailbox (F3)

● Copy to Mailbox (Shift-F3)

● Open Mailbox (F4)

● QuickOpen Mailbox (Shift-F4)

● Add Keyword (F5)

● Set Project (Option-F5)

● Compose with Template (F6)

● Reply with Template (F7)

● QuickReply with Template (Option-F7)

Note: The last three options, involving templates, are covered in the Using 
Templates topic, and more specifically in Use Custom Templates.

Apply Keystroke Rules
You can create any number of Keystroke Rules, which are just like inbox and 
outbox rules except that instead of applying automatically on incoming or 
outgoing messages, they apply only when you press a user-defined keyboard 
shortcut. If you forget which keyboard shortcuts you’ve applied, you can open the 
Apply Keystroke Rules panel by pressing F2. Then use the arrow keys (or type in 
the Search field to find a rule) to select a keystroke rule and press Return to 
apply it.
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Move to Mailbox
MailMaven lets you move any message to any mailbox quickly—in any account, 
no matter how deeply nested, and even if you don’t remember where that 
mailbox is. With one or more messages selected, press F3 to open the Move to 
Mailbox panel.
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Optionally type part of the mailbox name to filter the list, then press the keyboard 
shortcut next to a mailbox, select it in the list using your mouse, or use the arrow 
keys and then press Return.

Tip: To toggle between showing mailboxes only for the current account and the 
mailboxes for all accounts, press ⇧⌘A.

To move the selected messages to a mailbox and go to that mailbox at the same 
time, press Option (⌥) while selecting the mailbox, or add Option to the key‐
board shortcut.
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QuickMove to Mailbox
The QuickMove to Mailbox panel (Shift-F3) is like a streamlined version of the 
Move to Mailbox panel: it contains only the mailboxes (up to 10) you’ve designat‐
ed as the ones you use most often in Settings > Process > Message Filing > 
QuickMove Mailboxes.

Once the QuickMove to Mailbox panel is open, you can simply press the number 
beside any mailbox to move the selected messages to that mailbox.
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Tip: Even without the QuickMove to Mailbox panel open, you can press ⌃⌘ plus 
that number to move a message to that mailbox. In this example, pressing ⌃⌘5 
moves the message to the Family mailbox.

Copy to Mailbox
The Copy to Mailbox panel is just like the Move to Mailbox panel, except that it 
duplicates the selected messages to the destination mailbox.

To copy the selected messages to a mailbox and go to that mailbox at the same 
time, press Option (⌥) while selecting the mailbox, or add Option to the key‐
board shortcut.
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Open Mailbox
Although you can select any mailbox in the MailMaven viewer window to display 
its contents, you can also open any mailbox using the Open Mailbox panel (F4).

Optionally type part of the mailbox name to filter the list, then press the keyboard 
shortcut next to a mailbox, select it in the list using your mouse, or use the arrow 
keys and then press Return.

QuickOpen Mailbox
Just as QuickMove to Mailbox is a streamlined version of Move to Mailbox, 
QuickOpen Mailbox (Shift-F4) is a streamlined version of Open Mailbox, showing 
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up to 10 of your favorite mailboxes as set in Settings > Process > Message Filing 
> QuickOpen Mailboxes.

Once the QuickOpen Mailbox panel is open, you can simply press the number 
beside any mailbox to open that mailbox.

Tip: Take note of those numbers! Even without the QuickOpen Mailbox panel 
open, you can press ⌘ plus that number to open that mailbox. In this example, 
pressing ⌘7 opens the Tags tab.
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Add Keyword
You can add keywords to the selected message(s) in numerous ways, such as 
clicking the Tag Message  icon, choosing Message > Set Tags, or pressing 
⌃⌘T. Yet another way is to call up the Add Keyword panel by pressing F5.

Here you can do any of the following:

● Type part of an existing keyword to filter the display, then select the one you 
want using the mouse, or select it using the arrow keys and press Return.

● Press the keyboard shortcut shown next to a keyword to apply it.
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● Type a new keyword and press Return.

Set Project
Just like the Add Keywords panel, the Set Project panel (Option-F5) lets you add 
a project tag to the selected message(s).

You can then:

● Type part of an existing project to filter the display, then select the one you 
want using the mouse, or select it using the arrow keys and press Return.

● Press the keyboard shortcut shown next to a project to apply it.
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● Type a new project name and press Return.

Rules
Rules should be familiar to anyone who has used Apple Mail, Microsoft Outlook, 
Gmail, or other popular email apps. A rule is simply a description of what condi‐
tion(s) to look for in a message (such as a particular subject or sender, or a 
phrase in the body of the message) and what action(s) to perform when a 
message matches that description (delete the message, file it in a particular 
mailbox, or send a boilerplate reply, say).

MailMaven’s rules offer considerably more power than Apple Mail’s, and can 
interact with tags and notifications in a variety of ways.

Rule Basics
The process of creating a rule is almost identical regardless of where it’s used, 
although a handful of conditions and actions apply only in certain contexts (for 
example, Junk Status doesn’t apply to outbox rules, and only keystroke rules can 
apply other rules as one of their actions).

To create a rule:

1. Go to Settings > Process > Inbox Rules, Outbox Rules, or Keystroke Rules 
(depending on your needs).

2. Click the plus  icon. The new rule dialog appears.
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3. Type in a name for your rule.

4. In the top portion, which specifies what conditions to look for, choose Any or 
All from the pop-up menu to specify whether the rule should match a message 
even if only one condition is true, or whether all conditions must be true. (For 
messages with only one condition, this setting makes no difference.)

5. Set the first condition by choosing a category (such as Subject, From, or Date 
Received) from the leftmost pop-up menu. Then use the remaining pop-up 
menu(s) or field(s) to fill in the rest of the condition, such as:

[Subject] [contains] MailMaven

[From] [is] suzieq@smallcubed.com

[Date Received] [is between] 3 and 7 [days] ago

[# Attachments] [is at least] 5

6. To add another condition, click the + Condition  button and choose 
a condition from the pop-up menu. To create compound conditions (for 
example, to use All for the overall list of conditions but Any for a subset of 
conditions), choose Compound from the leftmost pop-up menu.
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7. To add an action, click the + Action  button and choose an action 
from the pop-up menu. As with conditions, you may have to use pop-up 
menus or fields to fill in the details, such as:

Add Keywords Taxes 2025

Set Importance [High]

Move Message to [Archives]

Set Read Status [Unread]

8. Repeat step 7 to add more actions, if you like.

9. Click OK.

You can create as many rules as you like using this process, and you can select 
or deselect the Enabled checkbox to enable or disable any given rule.

Inbox Rules
Rules you create on the Inbox Rules tab (assuming their Enabled checkbox is 
selected) run automatically on all new incoming messages as they appear in your 
inbox. Rules apply sequentially in the order shown; drag rules to change the 
order. If you want MailMaven to stop looking at further rules once a certain rule 
has matched a message, add the action Stop Applying Rules.

Outbox Rules
Rules you create on the Outbox Rules tab (assuming their Enabled checkbox is 
selected) run automatically on all outgoing messages as you send them. As with 
inbox rules, outbox rules apply sequentially in the order shown; drag rules to 
change the order. If you want MailMaven to stop looking at further rules once a 
certain rule has matched a message, add the action Stop Applying Rules.
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Keystroke Rules
Rules you create on the Keystroke Rules tab (as always, assuming their Enabled 
checkbox is selected) run only when you press the keyboard shortcut you define. 
To tell MailMaven which keystroke to use, enter a character in the Key field in the 
upper-right corner of the rule window, with or without the modifiers Shift (⇧) and 
Option (⌥). Then, by default, pressing Control plus that key performs the rule.

Although you can’t change the keystroke rule modifier key to anything other 
Control, you can disable Control-key shortcuts by selecting “Use Control+Key to 
Apply Rules to Selected Messages.” In that case, you can still apply keystroke 
rules by opening the Apply Keystroke Rules window (F2) and pressing the key 
you set.

Two additional notes about keystroke rules:

● You can use the same keystroke for multiple rules. In that case, pressing the 
keystroke applies the rules with that key in order.

● Keystroke rules can, in turn, run other rules, using the Apply Rule action.

Junk Mail
MailMaven does not have a built-in spam/junk mail filter, but it can use a filter on 
your email server, or a copy of SpamSieve running on your Mac, to categorize 
messages as junk. (In general, SpamSieve is far more accurate than most 
server-based spam filters.) Either way, you configure the way MailMaven handles 
spam in Settings > Process > Junk.

To rely on server-based filters that add headers indicating that a message is 
spam, select Evaluate Arriving Messages Using Spam Headers, and then use 
the pop-up menu to choose whether those messages should be moved to your 
Junk mailbox or kept in their original mailbox (usually the Inbox).

To use SpamSieve, instead select Evaluate Arriving Messages Using Spam‐
Sieve. For messages with a SpamSieve score of 50 or higher, choose how 

https://c-command.com/spamsieve/
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MailMaven handles that message using the pop-up menu; your choices are 
Move Message to Junk Mailbox (the default), Leave Message in Inbox, Move 
Message to Trash, and Delete Message Immediately. You can optionally set a 
different behavior for messages with a higher SpamSieve score by selecting 
“When SpamSieve Score Is Greater or Equal to,” entering a number (such as 
75), and making a different choice from the second pop-up menu.

Having done this, you can train SpamSieve from within MailMaven: select a 
message and choose Message > Mark as Junk (or drag it to the Junk mailbox) to 
tell SpamSieve it should be considered spam; or choose Message > Mark as Not 
Junk (or drag it out of the Junk mailbox) to tell SpamSieve it’s not spam. (For 
more information, see this page on SpamSieve’s site.)

Note: Unlike Apple Mail and most other email apps, MailMaven does not require 
a plugin or any extra software to communicate with SpamSieve—support is 
baked right in!

https://c-command.com/spamsieve/help/setting-up-mailmaven
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Message Organization
In MailMaven, organizing messages goes far beyond filing them into mailboxes. 
After all, not everyone has or wants an elaborate mailbox hierarchy, and many 
messages might fit into several different mailboxes. To supplement filing 
(whether done manually or by rules), MailMaven offers extensive tagging 
features.

Although you may be familiar with tags from apps like the Finder and Notes, what 
MailMaven considers tags is much broader: not just words and phrases (Key‐
words) but also numerous other types of metadata, such as review dates and 
projects, that help you organize and track your messages. You can apply tags 
manually (using any of several techniques) or automatically, using rules. And you 
can view and use tags in many places, too—including smart mailboxes and rules.

Note: To sync your tags across multiple Macs, use a sync profile as described in 
Sync Profile.

Tagging Messages
You can tag any message in MailMaven, including outgoing messages, using a 
variety of techniques.

Using the Tag Window
The Tag window is a place to see all the different tag types in one place and 
apply as many as you like to the selected message(s). You can open the Tag 
window in any of these ways:

● In a message you’re composing, click the Tag Bar if it’s visible (if it’s not 
visible, click the Toggle Tags  icon).
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● While viewing a message, click the Tag Message  icon on the Message 
Action Bar, or, to tag all messages in a conversation, click the Tag All Mes‐
sages  icon on the Conversation Action Bar at the top.

● With one or more messages selected, choose Message > Set Tags or press 
⌃⌘T.

● Right-click (or Control-click) a message and choose Add Tags from the 
contextual menu.

Regardless of how you invoke it, the Tag window looks something like this:

Although the Tag window initially appears as a popover, you can drag it to 
reposition it anywhere on the screen as a standalone window. Either way, the 
appearance varies slightly depending on whether you have one or more mes‐
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sages selected, and the window has extra controls for messages you’re compos‐
ing.

There are nine different tag types, most of which can be applied in a variety of 
ways besides using the Tag window. The tag types, discussed individually 
ahead, are:

● Keywords

● Project

● Importance

● Review Date

● Expected Reply

● Background Color

● Notes

● Alternate Subject

● Flag

If you want to hide some of these tag types in the Tag window, you can deselect 
the corresponding checkbox in Settings > Tag > General > Tag Window.

Tip: You can navigate up or down through the various sections of the Tag 
window by pressing ⌘▲ or ⌘▼. You can also expand or compress the Keywords 
section by pressing the ◀︎ or ▶︎ key or clicking the disclosure  or  arrows.

Once you have applied whatever tags you want, you can save the tags and 
dismiss the popover by clicking anywhere outside it or pressing ⌘↩. To dismiss 
the popover without saving changes, press Esc.



70

Tagging Outgoing Messages
When you apply a tag to an outgoing message, it’s associated with the copy of 
the message stored in Sent Messages—your archival copy. However, you can 
also optionally include tags in an outgoing message itself (as hidden headers), 
which means that recipients who also use MailMaven will see and be able to use 
those tags. 

To send tags with just a particular outgoing message, select the Send Tags With 
Message checkbox in the tagging window. Or, to change MailMaven’s settings so 
these tags are always sent by default, go to Settings > Compose > Display and 
check Send Tags With Messages.

Applying Tags with Rules
Any rule (inbox, outbox, or keystroke) can apply or remove tags by choosing the 
following actions:

● Set Color

● Set Flag

● Clear Tags

● Adopt Tags Sent With Message (not applicable to outbox rules)

● Remove Keywords

● Add Keywords

● Set Project

● Set Importance

● Set Review Date

● Set Note

See Rules for more information on creating rules.
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Note: The only tag type you can’t assign via a rule is alternate subject, because 
by nature that’s specific to each individual message.

Tag Types
Here’s a description of each of MailMaven’s nine tag types, including how to 
apply them and where to use them.

Keywords
A keyword is a word or phrase used to label messages. A typical use of key‐
words is to describe messages using one or more words that don’t necessarily 
appear in the message itself, such as recipe, taxes, or travel, making it easier 
for you to locate messages later that share that characteristic. A message can 
have any number of keywords.

You can add keywords in any of these ways:

● Use the Keywords section of the Tag window (see Using the Tag Window).

● Choose Message > Set Keywords (⌃⌘K).

● Right-click (or Control-click) a message and choose Set Keywords from the 
contextual menu.

● Open the Add Keywords panel by pressing F5, or from the Action Panel.

In any of these places, you can add a single-word keyword simply by typing it 
and pressing Space, Return, or comma. However, for frequently used keywords, 
MailMaven offers extra convenience features:

● When you use a keyword, MailMaven remembers it, so when you start typing 
keywords in the future, matching terms are suggested automatically.

● By default, newly added keywords appear on your Preferred List in Settings > 
Tag > Keywords. Preferred keywords are those you use most often, and when 
applying keywords, you can filter the list to show only preferred keywords if 
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you like. To prevent newly added keywords from becoming preferred, uncheck 
“Add New Keywords to Preferred List as.”

● To edit preferred keywords, add new keywords (including multiple-word phras‐
es), and set other keyword-related options, go to Settings > Tag > Keywords.

Note: Labels on messages in Gmail accounts and categories on messages in 
Exchange accounts are converted to Keywords in MailMaven.

Once you’ve added one or more keywords to a message, you can see them 
below the message snippet in snippet view, in the message header area in the 
message pane/window, and in the Keywords section of the Tag Mailboxes 
sidebar. Keywords can also be used in defining rules and smart mailboxes, and 
as part of a search.

Project
A project, like a keyword, is a word or phrase used to label messages, and 
conceptually, they’re mostly interchangeable. However, a project is intended to 
mean just that: a work, school, or personal undertaking. For example, you might 
have a Build Robot Army project, and apply that project tag to all your correspon‐
dence on that topic. But messages within that project may also have keywords 
that apply to other projects, such as coding, product design, and Skynet. And, 
unlike keywords, a message can have only one project.

You can add a project tag in any of these ways:

● Use the Project section of the Tag window (see Using the Tag Window).

● Choose Message > Set Project (⌃⌘P).

● Right-click (or Control-click) a message and choose Set Project from the 
contextual menu.

● Open the Set Project panel by pressing ⌥F5, or from the Action Panel.
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In any of these places, you can add a single-word project name simply by typing 
it and pressing Space, Return, or comma. For frequently used project names, 
MailMaven offers extra convenience features just like those for keywords:

● When you use a project, MailMaven remembers it, so when you start typing 
project names in the future, matching terms are suggested automatically.

● Preferred projects are those you use most often, and when applying projects, 
you can filter the list to show only preferred projects if you like. To make newly 
added project names preferred by default, go to Settings > Tag > Projects and 
uncheck “Add New Projects to Preferred List as.”

● To edit preferred projects, add new projects (including multiple-word phrases), 
and set other project-related options (including a color for each project), go to 
Settings > Tag > Projects.

Once you’ve added a project to a message, you can see it below the message 
snippet in snippet view, in the message header area in the message pane/
window, and in the Projects section of the Tag Mailboxes sidebar. Projects can 
also be used in defining rules and smart mailboxes, and as part of a search.

Importance
A message’s importance is a marker you set, indicating the level of importance 
(from 1–5) you assign to a message.

Important: MailMaven’s importance tag does not correspond to the Priority 
label assigned in other email apps, such as Apple Mail.

You can add an importance tag in any of these ways:

● Use the Importance section of the Tag window (see Using the Tag Window).

● Choose Message > Set Set Importance and click the icon representing the 
level of importance you want.



74

● Right-click (or Control-click) a message and click the icon representing the 
level of importance you want from the contextual menu.

Once you’ve assigned an importance to a message, you can see it below the 
message snippet in snippet view, in the message header area in the message 
pane/window, and in the Importance section of the Tag Mailboxes sidebar. 
Importance can also be used in defining rules and smart mailboxes, and as part 
of a search.

Review Date
A review date is a tag you add that tells you a future date on which you want to 
look at a particular message again.

You can add a review date in any of these ways:

● Use the Review Date section of the Tag window (see Using the Tag Window).

● Choose Message > Set Review Date (⌃⌘R).

● Right-click (or Control-click) a message and choose Set Review Date from the 
contextual menu.

In any of these places, you can:

● Choose a preset from the pop-up menu (such as “Friday” or “in 3 days”). You 
can customize these in Settings > Tag > Review.

● Click the calendar  icon and select a date on the pop-up calendar.

● Type a word or phrase, such as Tomorrow or Next Thursday.

You can then monitor messages that may require review in the Review mailbox‐
es (see Review Mailboxes) or regular Smart Mailboxes. Depending on your 
settings in Settings > Tag > Review, MailMaven can display a notification when a 
message’s review date arrives. Review dates can also be used as part of a 
search.
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Note: MailMaven doesn’t add review dates to your macOS Calendar; this 
metadata, like all tag metadata, is specific to MailMaven.

Expected Reply
You can tell MailMaven that you’re expecting a reply to a message by adding a 
special keyword (Pending by default) to a message you’re composing or one in a 
Sent mailbox. To change which keyword is used to mark a message as expecting 
a reply, or to set other parameters for expected replies, go to Settings > Tag > 
Review and look in the Expected Replies section.

Messages marked with that keyword appear in the Expecting Reply category 
under Review mailboxes (see Review Mailboxes).

Background Color
A background color tag lets you apply a color to messages to help you keep 
visual track of those in certain categories.

You can add a color in any of these ways:

● Use the Background Color section of the Tag window (see Using the Tag 
Window).

● Choose Message > Set Background Color and click the icon representing the 
color you want.

● Right-click (or Control-click) a message and click the icon representing the 
color you want from the contextual menu.

By default, the color you apply appears as a bar to the left of the message in 
message lists and to the left of the header in the message pane/window. Howev‐
er, you can also display it as a background color (as the name implies) in 
message lists by going to Settings > Tag > Colors and choosing Background 
from the Message List Color Location pop-up menu.
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Notes
A note is just that: extra information about a message you add for your own 
future reference.

You can add a note in any of these ways:

● Use the Notes section of the Tag window (see Using the Tag Window)

● Choose Message > Set Note (⌃⌘N)

● Right-click (or Control-click) a message and choose Set Note from the 
contextual menu.

Notes appear below the snippet in Snippet view, and in the message header 
area in the message pane/window, and can be used as part of a search.

Alternate Subject
An alternate subject is the subject you think a message should have, not neces‐
sarily what the sender thought it should have!

Note: Alternate subjects aren’t available for outgoing messages, since Mail-
Maven assumes you’ll use the subject you actually want!

You can add an alternate subject in any of these ways:

● Use the Alternate Subject section of the Tag window (see Using the Tag 
Window).

● Choose Message > Set Alternate Subject (⌃⌘S).

● Right-click (or Control-click) a message and choose Set Alternate Subject 
from the contextual menu.

When you do this, MailMaven shows your subject in the Subject header through‐
out the app.
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Flag
A flag is an icon in the shape of a flag that can be in any of seven colors. When 
you want to quickly make certain messages stand out in a mailbox without using 
specific keywords, a flag is a good option. A given message can have only one 
flag color.

You can add a flag in any of these ways:

● Use the Flag section of the Tag window (see Using the Tag Window).

● Choose Message > Set Flag and click the icon representing the flag you want.

● Right-click (or Control-click) a message and click the icon representing the 
flag you want.

Once you’ve added a flat to a message, you can see it below the message 
snippet in snippet view, in the message header area in the message pane/
window, and in the Flags section of the Tag Mailboxes sidebar. It can also be 
used in defining rules and smart mailboxes, and as part of a search.

Tags and Gmail Labels
In general, Gmail labels are equivalent to MailMaven keywords. For example, 
any messages in your Gmail account in MailMaven should be tagged with 
keywords representing whatever labels are applied in Gmail.

However, there are several qualifications due to the differences in how Gmail 
treats labels (via IMAP) and how MailMaven handles keyword tags:

● Keywords can be specific to MailMaven (the default), Universal (applying both 
to MailMaven and to Gmail), or Gmail-specific. To make sure any newly 
created keywords in MailMaven can be used as Gmail labels, go to Settings > 
Tag > Keywords and choose Universal Keyword/Label from the “Add New 
Keywords to Preferred List as” pop-up menu. Or, to change a particular 
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keyword to be universal, double-click in in the list, select Universal Keyword/
Label, and click Save.

● MailMaven uses a subtle styling change to differentiate MailMaven-only key‐
words from those that can be used with Gmail. MailMaven-only labels have 
rounded corners and a light blue background ( ), while Gmail labels 
have square corners and a darker blue background ( ).

● When you’re sending a message from your Gmail account within MailMaven, 
any keywords you add to that message that are either universal or Gmail-
specific should appear on the Sent message on the Gmail site as labels. 
Similarly, if you add a universal or Gmail-specific keyword/label to any existing 
message in your Gmail account, it should appear in your Gmail account as a 
label.

● In order for MailMaven to be able to “see” a label applied in Gmail, that label 
must be visible via IMAP. To check this, sign in to your Gmail account in a 
browser. Click the settings  icon > See all settings > Labels. At the bottom 
of the list, under the Labels heading, every Gmail label that you want Mail‐
Maven to be able to see should have Show in IMAP checked.

● If you add a Gmail label to a message from a non-Gmail account, it behaves 
as a regular keyword.

● You can’t delete Gmail labels from with MailMaven, though you can select the 
Muted checkbox in Settings > Tag > Keywords to hide them. If you want to 
delete a Gmail label completely, you must do that on the Gmail site.
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The Search Window
MailMaven offers numerous ways to locate messages quickly, even if you have 
hundreds of thousands of them. If you’ve applied tags to message (see Tagging 
Messages), you can use the Tag and Review Mailbox categories in the sidebar 
to help narrow your search (see Tag Mailboxes and Review Mailboxes). For 
searches you keep coming back to, Smart Mailboxes are your friend. And, to 
quickly narrow down the contents of the current mailbox, Filter Controls can be a 
big help.

However, when you need more power than those tools can provide, MailMaven’s 
Search window is what you want. Open it by choosing Find > Search for Mes‐
sages (⇧⌘F) or by clicking the Search  icon on the toolbar.
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Search Basics
As you begin typing into the search field at the top, MailMaven immediately 
begins looking for senders, recipients, subjects, tags, projects, mailboxes, and 
attachments that match whatever you’ve typed and displays a menu of sug‐
gestions. For example, if you frequently email someone named Federighi (and 
really, who among us does not?), tying in fed is bound to pop up that person’s 
name and email address among the top matches. You can then use the mouse 
or the arrow keys (followed by Return) to select that suggestion. Type more 
letters and you’ll get closer matches.

You’re also free to ignore the suggestions completely; type whatever word(s) 
you’re looking for and press Return, and MailMaven performs an exhaustive 
search for them.

The pop-up menu to the left of the Search field has two options: All (the default) 
or Any. What you choose here determines how MailMaven behaves when your 
search term contains more than one word (or more than one criterion). For 
example:

● If you want to search for messages that contain both the word pudding and 
the word banana, you should set that to All and enter pudding banana (in either 
order). Maven then performs an AND search, looking for messages containing 
both those words, even if they aren’t next to each other.

Note: Type a space or a comma between terms to make the search treat them 
as separate elements.

● If you want to search for messages that contain either of those words, but not 
necessarily both (an OR search), set the menu to Any, and again type in 
pudding banana.

● If you want to search only for messages that contain the exact phrase “banana 
pudding,” you can do any of the following:
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▶ Type "banana pudding"

▶ Press the down arrow ▼ key, select Phrase, and then type banana pudding

▶ Type phrase: banana pudding

● You can type a plus (+) or minus (-) before a search term to include or exclude 
it. For example, to find messages that contain “banana” but not “pudding” you 
can enter banana -pudding. To narrow down the search further to only those 
messages that also include the word “pie” you could enter banana -pudding 
+pie.

● To clear all the search criteria and start over, click the X  icon on the right 
side of the Search field.

That’s just the beginning, though. You can adjust the search scope (which 
accounts or mailboxes MailMaven looks in) and use search tokens to look for 
specific data within a message.

Search Scope
If you want to look through all messages in all mailboxes in all accounts, make 
sure All Messages is selected in the upper-left corner of the Search window, as it 
is by default. Or, to look in just one account or mailbox, use that pop-up menu to 
navigate to your desired location. Either way, you can optionally select any or all 
of Trash, Junk, and Sent to include those mailboxes in your search. Although 
new searches always start with your default search scope, MailMaven remem‐
bers the state of the Trash, Junk, and Sent checkboxes.

Tip: You can customize the default search scope. See Appearance Tab.
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Search Tokens
Search tokens are markers you can insert to tell MailMaven to narrow your 
search in a particular way. If you accepted one of the search suggestions (such 
as Address Contains: Scott), the criterion you selected appears in a gray bubble 
to the left of your search term. That bubble is the token.

[ANY ADDRESS Scott]

You can also apply a token in the following ways:

● With your insertion point in the Search field, press the down arrow ▼ key. A 
rather long pop-up menu appears with all the available search tokens. (The 
menu is split into three sections here.)

● Start typing the first characters of a token name (such as PHRASE, REVIEW 
DATE, ACCOUNT, or SUBJECT). Then select that token and continue typing 
your search term.
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To change an existing token (for example, from TO to ANY RECIPIENT), click 
the token in the search field and choose the one you want from the pop-up menu.

Important: Search tokens always affect the text that follows them.

When you use a DATE RECEIVED or REVIEW DATE token, you must then start 
typing something (such as yesterday, this week, or July 1, 2025) and make a 
choice from suggestion list; leaving plain text after either of those tokens won’t 
work.

Multiple Search Criteria
You can search for multiple criteria at once! For example, you can search for 
FROM name@example.com SUBJECT trees DATE RECEIVED Yesterday. Do do 
this, enter your first token followed by a search term, then either press the down 
arrow ▼ key to display the token menu, type part of a token name, or type a 
space and then part of the next term to display suggestions.

If you’re performing an Any search with multiple criteria, you can select any of the 
search tokens and press ⌘- (Command-minus) to exclude it or ⌘+ (Command-
plus, or Command-Shift-minus) to require it. When you do this, the token gets a – 
or + sign before it, as in –KEYWORD banana.

You can also use multiple criteria to combine an OR search with an AND search. 
For example, if you have an Any search for banana pudding, that returns mes‐
sages containing either term. But if you then add the ALL WORDS token followed 
by dessert menu, MailMaven searches for messages that contain either “banana” 
OR “pudding” OR both “dessert” and “menu.”
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The Settings Window
The Settings window (MailMaven > Settings) contains hundreds of options that 
let you customize nearly every aspect of MailMaven’s behavior. It’s organized 
into seven main panes, some with multiple tabs to organize settings into sub‐
groups.

The majority of settings are self-explanatory. This page provides an overview of 
each pane and tab, calling out a handful of key settings and providing further 
guidance in a few areas that may not be obvious.

General Settings
The General pane contains settings that affect the MailMaven app as a whole.

Application Tab
On the Application tab, you can change the overall color scheme from purple to 
something else using the Theme Color pop-up menu. You can also set your 
Mac’s default email app (to MailMaven or something else), change the frequency 
of checking for new messages and synchronizing all your mailboxes, and set the 
behavior of the Refresh Mail button.

Note: Synchronizing does more than merely check for new messages; it 
compares the list of messages in all your MailMaven mailboxes with what’s on 
the mail server(s), bringing the two in sync in case changes in one place weren’t 
immediately picked up in the other.

Keystrokes Tab
The Keystrokes tab lets you configure keyboard shortcuts for dozens of common 
activities. At the top of the tab, you can select Maven (to use MailMaven’s 
defaults), Gmail (to use Gmail’s defaults, where applicable), or Custom (to set 
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your own, with MailMaven’s defaults prefilled for you. With Custom selected, click 
in a field and press the keyboard shortcut you want to use for that action.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your Keystrokes settings (as a backup, or to transfer to 
another Mac).

Notification & Badges Tab
On this tab, configure how you want MailMaven to notify you about new incoming 
messages, messages to which Keystroke Rules have been applied, and mes‐
sages with review dates (see Review Date), as well as the appearance and 
behavior of the unread message badges on MailMaven’s Dock icon and menu 
bar icon.

Tip: Click the badge on the large icon shown on this tab to customize its color, 
size, shape, and other attributes; drag the badge to the center or a different 
corner of the icon to make it appear there; and click the plus  icon to add 
another badge (yes, really—you can have up to five!) showing different informa-
tion.

Accounts Settings
The Accounts pane is where you configure each of the email accounts you want 
to use with MailMaven. It’s also where you can optionally set up a sync profile 
that enables MailMaven to sync the tags for all your messages with any other 
Macs you use.

Mail Accounts Tab
To add or configure an email account, go to the Mail Accounts tab. MailMaven 
supports all IMAP accounts (including Proton Mail accounts via the Proton Mail 
Bridge app), as well as iCloud, Gmail/Google Workplace, Microsoft Exchange/
Office 365/Outlook, and Yahoo!/AOL. POP accounts are not currently supported.
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Note: If you migrated your accounts from Mail when first setting up MailMaven 
(see Migrating from Apple Mail), this tab may already be fully configured.

To add a new account:

1. Click the plus  icon at the bottom of the account list.

2. Enter the account’s email address and your name (that is, the name you want 
to appear in the From line of messages sent from this account). Click Contin‐
ue.

3. On the next screen, confirm (and edit if necessary) your name and email 
address, and optionally edit the account name (the way the account appears 
in MailMaven).

MailMaven automatically chooses a color for your account, which is used 
throughout the app to help you distinguish one account from another. If you 
don’t like the preselected color, click the color swatch and select a different 
one.

If MailMaven has not automatically selected the correct account type, click the 
gear  icon, click Override Account Type, choose the account type you want 
to use, and click OK.

4. Depending on the account type, you may then see:

▶ A password field. Fill in your password for that account and click Authorize. 
(For iCloud accounts, you’ll need a special app-specific password; see 
App-Specific Passwords, below.)

▶ An Authorize button only. Click this and follow the steps to authenticate 
(see About MailMaven and OAuth, just ahead).

5. MailMaven attempts to figure out which mailboxes on the server should be 
used for the special mailboxes Drafts, Sent, Trash, Archive, and Junk, as 
shown in the Special Mailboxes section. To use a different mailbox for any of 
these purposes, choose it from the appropriate pop-up menu.
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6. MailMaven also assigns an icon to each account, which is branded in the case 
of major providers such as Gmail, iCloud, and Exchange, but a generic 
silhouette icon for regular IMAP accounts. If you prefer a different icon, click 
the current icon (labeled with an EDIT badge) and select a different image 
from those shown, or click Select From Disk and navigate to the image file of 
your choice.

Repeat these steps for as many accounts as you like. To change account details 
later, select the account 

To remove an account from MailMaven, click the minus  icon at the bottom of 
the account list.
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About MailMaven and OAuth
MailMaven relies on an industry standard called OAuth (for open authentication) 
when used with certain email providers, such as AOL, Gmail, Microsoft 
Exchange/Outlook, and Yahoo!, to securely verify your credentials when signing 
in to your account. With this mechanism, clicking Authenticate (or Reauthenti-
cate) in MailMaven opens the provider’s authentication page in your default web 
browser. Once you’ve entered your credentials there and the email provider has 
verified them, a secure token is stored in your Mac’s keychain.

While this method does require a few more clicks than merely typing in your 
username and password, it’s designed to be safer, as it eliminates the need for 
MailMaven to ever see or store your password itself.

App-Specific Passwords
Some email providers, such as iCloud and Fastmail, employ a special security 
measure when accessing them from an app other than their own. Rather than 
using OAuth, they require an app-specific password—a special password you 
generate for the use of a single app.

Important: Entering your regular iCloud password in MailMaven will not work.

To get an app-specific password for iCloud, do this:

1. Go to account.apple.com and sign in.

2. Click App-Specific Passwords.

3. Click the plus  icon.

4. Enter the name of the app (in this case, MailMaven) and click Create. When 
prompted, confirm your identity using your Apple Account password.

5. Your new app-specific password for MailMaven appears on the screen. 
Immediately copy this and store it in a safe place, such as a password manag‐
er.

https://en.wikipedia.org/wiki/OAuth
https://account.apple.com
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Warning! This is the only time Apple shows you the app-specific password. If 
you don’t make a note of it, you’ll have to revoke the old password and create a 
new one.

Importing from Mail
During the initial MailMaven setup process, you’re prompted to import accounts, 
mailboxes, and messages from Apple Mail. If you skip that for one or more 
accounts, or if you later want to import additional accounts or “On My Mac” 
mailboxes, click the Import  icon at the bottom of the account list in Settings > 
Accounts > Mail Accounts and follow the prompts.

Sync Profile
Tags you apply to messages (see Message Organization) are stored separately 
from your messages themselves in a special database on your Mac. If you use 
MailMaven on more than one Mac, you’ll surely want the same tags to appear in 
each copy. To accomplish this, MailMaven gives you the option to sync just the 
tag data (not message contents or headers) with your other Macs via Small‐
Cubed’s servers. Tag data is encrypted end-to-end and can’t be read by Small‐
Cubed.

To set this up, you first need an account called a sync profile. If you don’t already 
have one, go to Settings > Accounts > Sync Profile, click Create, and follow the 
prompts to sign up with an email address and password.

If you already have a sync profile, go to Settings > Accounts > Sync Profile and 
click Link. Choose the appropriate email address from the pop-up menu, enter 
your profile password, and click Use Existing Profile.

Once you’ve set up and linked a profile, select the checkboxes for each account 
whose tag data you want to sync. (On any given Mac, even when signed in, you 
can choose to sync tag data from any, all, or none of your email accounts.)

Repeat this procedure on each of your Macs.



90

View Settings
On the View pane are settings related to how the viewer window, messages, 
conversations, and other elements of the user interface appear and behave.

Appearance Tab
The Appearance tab has five subsections:

● Viewer Layout: Select whether Snippets or Table is the default view, adjust 
details of the appearance for each, and select elements to show, hide, or 
highlight.

● Search: Set the default search type (All Words by default, but you may prefer 
Any Word) and the default scope (All Messages by default, but you can 
choose a more restricted scope from the pop-up menu).

● List View Email Addresses: Configure the way you want addresses and 
recipient markers to appear in message lists. 

● Conversation Panel: Optionally check either or both of these boxes to show 
the Conversation panel when you select any message that’s part of a conver‐
sation and hide it when you no longer have such a message selected.

● Mailbox/Account Information: Choose whether to show the account color, 
icon, and name next to the subjects in message lists.

Message Display Tab
Controls related specifically to how individual messages appear are on this tab, 
divided as follows:

● Headers: Adjust the appearance of the Message Header area.

● Fonts & Zoom: Set the default font and size for both rich text and plain text 
messages, and the default zoom level.

● Quoted Content: Set colors and appearance of quoted text in replies.
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● Images: Set defaults for whether and when remote media should load 
automatically.

● Attachments: Specify how you want various kinds of attachments to appear 
within a message.

● Message Action Bar: Choose where and when the Message Action Bar 
appears (see Basic Message Controls) and what the Action  icon does.

Behaviors Tab
On this tab, adjust when (if at all) messages are marked as read, whether to 
archive sent messages, and what the Space bar does in various contexts.

Compose Settings
The Compose pane contains settings that pertain to the creation of email 
messages (including new messages, replies, and forwards).

Display Tab
The Display tab lets you configure a number of things about the look and 
behavior of messages you’re creating:

● Composition: Choose defaults for the address format, content type (rich text 
or plain text), font and size, and auto-save.

● Default Sender: For users with multiple email accounts, determine how 
MailMaven picks which address to send new messages from by default, and 
what the fallback address is if the default can’t be used for any reason. (Best 
Guess takes context into account, such as which account, mailbox, or mes‐
sage is selected when you reply, forward, or create a new message.)

● Outboxes: Use this pop-up menu to set when the Outbox appears.

● Delivery Options: Decide whether the Delivery Options Bar is visible by 
default, and what the default settings are for several delivery options.
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Signatures Tab
Set up signatures here, as explained fully in Adding a Signature.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your signatures (as a backup, or to transfer to another Mac).

Templates Tab
On this tab, create and edit templates as described in Using Templates.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your templates (as a backup, or to transfer to another Mac).

Tag Settings
Settings for the many ways in which MailMaven can tag messages are on the 
Tag pane. Although you can use most of the tagging features without any 
configuration at all, this pane lets you customize many behaviors to your exact 
preferences.

General Tab
On the General tab, select which types of tags appear in the Tag Window (all are 
enabled by default) and whether replies and forwarded messages inherit key‐
words or projects from the original message (both are turned off by default).

Keywords Tab
You can add keyword tags on the fly to any message (see Keywords), and, by 
default MailMaven remembers previously used keywords so it can autofill them 
as you type matching characters. If you don’t want MailMaven to do this, go to 
the Keywords tab and deselect “Add New Keywords to Preferred List as.” You 
can also set the number of recent keywords to show and what their sort order 
should be.
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In the Keywords table, you can create new keywords you haven’t yet used, edit 
or delete existing keywords, and (for Gmail accounts) mute individual keywords. 
For other Gmail-specific settings on this tab, refer to Tags and Gmail Labels.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your Keyword settings (as a backup, or to transfer to another 
Mac).

Projects Tab
On the Projects tab, you can create, edit, or mute projects (see Project) and 
adjust a few project-related settings.

Tip: You can use the Export  and Import  icons at the bottom of the tab to 
export or import your Project settings (as a backup, or to transfer to another 
Mac).

Review Tab
Settings related to Review Date tags are on the Review tab. You can configure 
two default review dates that appear when you tag a message, either of which 
can be a specific day of the week (such as the next Thursday) or a number of 
days (such as three days from now). You can also enable notifications when a 
message reaches its review date and configure Expected Reply settings.

Colors Tab
On the Colors tab, configure which colors are used with Background Color tags 
as well as with review dates and importance.

Process Settings
The Process Settings pane offers controls for the tools MailMaven uses to help 
you process messages (either automatically or manually): rules, the Action panel, 
QuickMove to Mailbox, QuickOpen Mailbox, and junk mail filtering.
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Inbox Rules Tab
The Inbox Rules tab lets you configure rules that run automatically on each new 
incoming message as it’s received. See Inbox Rules for details.

Outbox Rules Tab
The Inbox Rules tab lets you configure rules that run automatically on each new 
outgoing message as it’s sent. See Outbox Rules for details.

Keystroke Rules Tab
The Keystroke Rules tab lets you configure rules that run on demand when you 
press a user-specified keyboard shortcut. See Keystroke Rules for details.

Message Filing Tab
The Message Filing tab lets you set up to ten mailboxes each to be used with 
keyboard shortcuts for QuickMove to Mailbox and QuickOpen Mailbox opera‐
tions. It also offers several ways to customize the Action Panel.

Junk Tab
The Junk tab lets you configure MailMaven’s spam filtering; see Junk Mail for 
details.

Secure Settings
The Secure pane contains controls for configuring MailMaven to encrypt and/or 
digitally sign messages using PGP (or its open-source counterpart, GPG/
GnuPG). For details, refer to Encrypting and Digitally Signing Messages.

The checkboxes at the top of the pane let you set defaults for encrypting and 
signing outgoing messages, but regardless of how you set this, you can override 
your choice for individual messages (see Encrypting and Digitally Signing 
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Messages). To store decrypted copies of messages on disk (and not just in 
RAM), select Cache Decrypted Messages.
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This documentation was written by Joe Kissell.

Copyright © 2025, SmallCubed.
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